Bug 14574 - Find references not finding a constructor usage
Summary: Find references not finding a constructor usage
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: 4.0.12
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-09-09 16:33 UTC by Jérémie Laval
Modified: 2013-09-12 03:17 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 Mike Krüger 2013-09-10 01:04:11 UTC
Works in master
Comment 2 Jérémie Laval 2013-09-10 11:52:31 UTC
Issue is when the file of the class is part of two different projects that are then linked by different projects. 

"Go to definition" brings to one that is not from the referenced project but rather the first one it encounters and then "Find references" only search in the project that link it.

I feel like this has already been reported in which case it would be a regression thus needs a test.
Comment 3 Mike Krüger 2013-09-10 12:02:08 UTC
We've tests for finding references.
Comment 4 Mike Krüger 2013-09-10 12:03:18 UTC
(btw. find references can't work this way - it's always searched starting at the definiton)
Comment 5 Jérémie Laval 2013-09-10 12:09:27 UTC
Then "Go to definition" is the one that is broken.

Watch: http://screencast.com/t/fyeiETlsWXz
Comment 6 Mike Krüger 2013-09-10 13:06:25 UTC
It's atm not supported in our shell I fear. 

we've a 1 to 1 relation between file names & projects :/
Comment 7 Mike Krüger 2013-09-12 03:17:23 UTC
should work better now