Bug 14547 - Fatal runtime generics issue after update to Xamarin.iOS 6.4
Summary: Fatal runtime generics issue after update to Xamarin.iOS 6.4
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 6.9.5.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-09 06:20 UTC by Prashant Cholachagudda
Modified: 2015-04-20 11:05 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Prashant Cholachagudda 2013-09-09 06:20:31 UTC
After upgrading to Xamarin iOS 6.4.4, the Async/await code throws an ExecutionEngineException exception. However it seems to work on X.iOS 6.4.3

"ExecutionEngineException: Attempting to JIT compile method 'ourapp.TouchTaskFactory:StartNew (System.Func`1)' while running with --aot-only. See http://docs.xamarin.com/ios/about/limitations for more information."

More details on the forum post here: http://forums.xamarin.com/discussion/7692/fatal-runtime-generics-issue-after-update-to-xamarin-ios-6-4
Comment 1 Sebastien Pouliot 2013-09-12 20:49:12 UTC
Please provide a slef-contained test case. A link to partial code is not enough to duplicate the issue.

note: the last part of the discussion thread is a bug alreaday fixed in 6.4.5 (but unrelated to a ExecutionEngineException).
Comment 2 Sebastien Pouliot 2015-04-20 11:05:26 UTC
Closing, no test case was provided and this area has seen many huge changes since XI 6.4.