Bug 14544 - ServiceHostFactory is not in correct assembly
Summary: ServiceHostFactory is not in correct assembly
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: WCF assemblies ()
Version: unspecified
Hardware: PC All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-09 05:22 UTC by mauzik
Modified: 2013-09-10 04:16 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description mauzik 2013-09-09 05:22:34 UTC
Hi,

I file a bug based on answer from Jonathan Pryor on mono forum http://mono.1490590.n4.nabble.com/Why-did-Mono-developers-merge-System-ServiceModel-Activation-dll-to-System-ServiceModel-dll-tp4660819p4660827.html

Type ServiceHostFactory is on Mono in assembly System.ServiceModel.dll, but in .NET is in System.ServiceModel.Activation.dll. 

Error message:
Error CS0012: The type `System.ServiceModel.Activation.ServiceHostFactory' is defined in an assembly that is not referenced. Consider adding a reference to assembly `System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' (CS0012) (TerminalServer)

Assembly System.ServiceModel.Activation.dll is not present in Mono framework. There is only assembly System.ServiceModel.dll that contains ServiceHostFactory.
Comment 1 Marek Safar 2013-09-10 04:16:14 UTC
Fixed in master. The type was moved to new assembly in .net 4.0.