Bug 14480 - Files are not saving
Summary: Files are not saving
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.1.10
Hardware: Macintosh Mac OS
: Highest normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-09-06 11:36 UTC by Alex Lovett
Modified: 2014-01-17 04:41 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alex Lovett 2013-09-06 11:36:12 UTC
Any changes I make in editor, when I goto Save it looks like it has saved, but reopening the file shows no changes have been saved. I have checked permissions, no errors in the log, very strange!

Even when I create a new C# file from inside Xamarin, it too will not save any changes, but it does create the file succesfully.

I recently upgraded to latest Alpha and started using Source Analysis

I have narrowed it down to being unable to save files on partitions and drives that are not the boot partition. If the files are on my boot drive they save fine. My drives are all formatted the same and have normal characters in name and such, and all of this was working perfectly earlier.

Moving my whole project to boot drive fixes this issue
Comment 1 Mike Krüger 2013-09-06 12:28:03 UTC
fixed
Comment 2 Vincent Bellet 2013-09-06 13:02:45 UTC
I had the same problem.

here a screencast in case the bug is still there :

http://zvalley-blog.s3.amazonaws.com/XS-bug.mov
Comment 3 narayanp 2014-01-17 04:41:25 UTC
I have checked this issue with following builds:

All Windows
X.S 4.2.3 (build 127)

I am successfully able to save file and changes always appears after reopening file. This is the screencast for the same: http://screencast.com/t/ZJlGMV9Uyr