Bug 14449 - Xamarin Studio crash when open/create a project
Summary: Xamarin Studio crash when open/create a project
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.12
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-04 22:05 UTC by Wilton Kwok
Modified: 2015-08-27 07:05 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of Terminal (223.47 KB, image/png)
2013-09-09 05:37 UTC, Wilton Kwok
Details
error Log (71.56 KB, text/plain)
2013-09-09 07:28 UTC, Wilton Kwok
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Wilton Kwok 2013-09-04 22:05:15 UTC
When I open/create a project. It crash.
Comment 1 Jason Ausborn 2013-09-08 01:17:40 UTC
There is a known issue causing a crash with Subversion 1.8 that is in progress. 

see bug 13600

Are you using Subversion 1.8 or greater?
Comment 2 Wilton Kwok 2013-09-09 05:37:50 UTC
Created attachment 4809 [details]
Screenshot of Terminal
Comment 3 Wilton Kwok 2013-09-09 05:38:58 UTC
I have checked my SVN version which is 1.6.18 as in the attached screenshot above
Comment 4 Jason Ausborn 2013-09-09 06:53:52 UTC
Do you have any errors in a log?

Check 

~/Library/Logs/MonoDevelop-{version}/

Or any other useful info relating to the crash?
Comment 5 Wilton Kwok 2013-09-09 07:28:24 UTC
Created attachment 4811 [details]
error Log

This is captured from the error window
Comment 6 Jason Ausborn 2013-09-09 08:37:47 UTC
Take a look here. 

http://monodevelop.com/developers/articles/user_profiles

You can try to delete the Cache and Temp files. Also take a look at the Profile Migration information there. 

This is not a guarantee to fix your issue, but you can try the MonoDevelop 4.1.9 Alpha release.

Regardless, make sure you install (or already have) Mono + GTK# (latest appears to be 3.2.1)

If these attempts fail, see if you get the same crash for creating a new project.

BTW, someone else may jump in with better information. If not, I will still try to help you if I can.
Comment 7 Jason Ausborn 2013-09-09 08:40:29 UTC
Also, what OS X version are you using?
Comment 8 Wilton Kwok 2013-09-09 08:42:28 UTC
Mac OS X 10.8.4. I can't find any folder with MonoDevelop in the ~/Library/* folder
Comment 9 Jason Ausborn 2013-09-09 08:55:33 UTC
BTW, sorry to ask about the OS version it was in the log you sent.

From the desktop, you can try to hit Command+Shift+G to get the Go To Folder.

If it comes up, type ~/Library/Caches

Some say it is bad to delete everything in this folder, so if you see any MonoDevelop folders just delete them. 

Try the same thing for Temp with ~/Library/Temp or just ~/Library/.

Sorry I don't use a Mac, but trying to help you will give me more info about troubleshooting MonoDevelop on other systems.
Comment 10 Jason Ausborn 2013-09-09 08:56:48 UTC
You have to add a trailing / at the end.
Comment 11 Alain 2013-09-10 11:00:41 UTC
Hi, 

I have the same problem !

Xamarin Studio crash with all version (stable, beta, alpha) on my iMac. On my MacPro, I don't have this crash.

For the moment, I work with the version 4.1.4 and that's run but not a other version

Alain
Comment 12 Jason Ausborn 2013-09-10 18:51:10 UTC
See bug 14266
Comment 13 Wilton Kwok 2013-09-11 00:12:17 UTC
I tried to download the Xamarin Studio 4.1.x but I can only download 4.0.x :(
Comment 14 Lluis Sanchez 2015-08-27 07:05:57 UTC
Can't be reproduced in current stable release. If you see this crash again, feel free to reopen.