Bug 1442 - Makefile goes to bad URL for get-monolite-latest
Summary: Makefile goes to bad URL for get-monolite-latest
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: High normal
Target Milestone: ---
Assignee: Duncan Mak
URL:
Depends on:
Blocks:
 
Reported: 2011-10-12 05:05 UTC by Bruce Mitchener
Modified: 2014-12-29 02:33 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Bruce Mitchener 2011-10-12 05:05:46 UTC
When doing a "make get-monolite-latest" to get a build going for the first time, it tries to fetch the code from:

    http://mono.ximian.com/daily/monolite-97-latest.tar.gz

But that doesn't appear to exist. I'm not sure what the correct location would be.

(I'm happy to put together a pull request if someone tells me the right URL.)
Comment 1 Bruce Mitchener 2011-10-12 05:08:26 UTC
Might be worth noting that http://mono-project.com/Compiling_Mono_From_Tarball links to daily tarballs which takes you to the page on ximian.com as well.
Comment 2 Zoltan Varga 2011-10-12 14:12:03 UTC
The monolite generation is currently broken and there is no ETA for when it will be back.
Comment 3 yanko 2012-01-11 15:31:10 UTC
So building from scratch is broken with no ETA on sight?

I use centos... Is there any solution for me? (other than use the outdated suse packages I mean)
Comment 4 Zoltan Varga 2012-01-11 15:34:28 UTC
Unfortunately, this seems to be the case.
Comment 5 yanko 2012-01-11 15:38:53 UTC
Ok, thanks for the quick reply :-). I'll try the suse route and then bootstrap.
Comment 6 Duncan Mak 2012-09-12 11:36:40 UTC
This has been fixed.

The link is http://storage.bos.xamarin.com/mono-dist-master/latest/monolite-105-latest.tar.gz