Bug 14415 - Unable to add External Tool in Xamarin Studio->Preference.
Summary: Unable to add External Tool in Xamarin Studio->Preference.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.1.10
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
: 14717 ()
Depends on:
Blocks:
 
Reported: 2013-09-04 05:21 UTC by narayanp
Modified: 2015-09-01 08:57 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-09-04 05:21:10 UTC
Steps to reproduce:
1. Open XS.
2. Click XamarinStudio->Preference
3. Select External Tool.
4. Add External Tool and click OK button.

Actual Result: After adding external tool it is throwing exception "System.Reflection.TargetInvocationException". However, when user change title of added external tool and click on OK button, It shows a popup showing 'The command of Tool .. is invalid'.

Expected Result: User should able to add external tool.

Supplement info:
http://screencast.com/t/HRjhhTkn
Error details: https://gist.github.com/saurabh360/24d7bd6e0545b471da6a  

Environment details:
All Mac
XS 4.1.10(build 6)
Mono 3.2.2

Regression Status:
We are seeing same behavior with Stable XS 4.0.12 and Stable XS 4.0.8(build 2) We are not sure it has ever worked or not.
Comment 1 Marius Ungureanu 2013-09-09 12:08:42 UTC
Well, in the second try, you had no command written, so it would be an empty command. I shall take care of this.
Comment 2 Marius Ungureanu 2013-09-09 12:25:49 UTC
Fixed and will be included in next releases.

The issues you were hitting on were mostly related to the Command section being blank. You cannot add a tool without a command.
Comment 3 narayanp 2013-09-20 03:39:43 UTC
Today I have checked this issue with following builds:

All Mac
X.S 4.0.13(build 37)
Mono 3.2.3

And we have observed that If we add and external tool and then provide and text in Command Text box and click on OK button the External tool get added successfully. However, If we change the title and provide text in command Text box then also Title gets changed and external tool get added successfully.

Changing the status to Verified.
Comment 4 Marius Ungureanu 2015-09-01 08:57:01 UTC
*** Bug 14717 has been marked as a duplicate of this bug. ***