Bug 14370 - Unable to launch XamarinStudio on Windows getting error "System.InvalidOperationException"
Summary: Unable to launch XamarinStudio on Windows getting error "System.InvalidOperat...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2013-09-02 02:30 UTC by Nischal
Modified: 2013-09-04 12:04 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Nischal 2013-09-02 02:30:09 UTC
Steps to reproduce:
1. Install Xamarin.Studion 4.1.10(build 3)
2. Launch XamarinStudio.

Actual Result: After installing XS when user launch XS on windows it is giving error popup which is mentioned in screencast: http://screencast.com/t/hfqenR6oi when user click on OK button on this popup it is giving another error popup: http://screencast.com/t/20f25wi0gD

Expected Result: User should able to launch XS on windows.

Supplement info:
Error details: https://gist.github.com/AkhileshKumar01/13f83ad1f61ccbdd3cbc

Environment details:
All Windows
XS 4.1.10(build 3)

Regression Status:
XS 4.1.9(build 6) working fine on Windows.
Comment 1 Mike Krüger 2013-09-02 04:17:56 UTC
Seems something is wrong with the install. 

Did you uninstall xs 4.1.9 first ?
Comment 2 narayanp 2013-09-02 10:47:40 UTC
Yes first we have uninstalled 4.1.9(build 6) and then we have installed XS 4.1.10(build 3)
Comment 3 Lluis Sanchez 2013-09-03 12:13:08 UTC
Does it launch if you launch it from the Windows menu?
Comment 4 Lluis Sanchez 2013-09-03 13:15:33 UTC
Should be fixed in 4.1.10 build 6
Comment 5 Prashant manu 2013-09-04 02:33:00 UTC
Today we have checked this issue with following builds:

All Windows
X.S 4.1.10 (buil6)

We are still not able to launch Xamarin Studio on Windows. As after installing XS. when we open XS on windows it is showing 'Xamarin Studio has stopped working' This is the gist of Program details: https://gist.github.com/saurabh360/6d2f9100a72327b126ee

Hence reopening this issue.
Comment 6 Lluis Sanchez 2013-09-04 08:32:55 UTC
Ok, that was a different issue. Fixed in XS 4.1.10 build 8.
Comment 7 Atin 2013-09-04 12:04:51 UTC
We have checked this issue with:

Windows 7 and 8
XS 4.1.10(build 8)

Now , we are able to launch XS on windows successfully without any exception. Hence marking this as Verified fixed