Bug 14319 - Unable to type into URL Schemes' text box when user set image for URL Type
Summary: Unable to type into URL Schemes' text box when user set image for URL Type
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 4.1.9
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-08-29 05:22 UTC by narayanp
Modified: 2013-09-05 14:42 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-08-29 05:22:53 UTC
Steps to reproduce this issue:
1. Open or create iOS application.
2. Open Project option->iOS Application->Advanced.
3. Click 'Add URL Type'.
4. Type in to URL Schemes Text box
5. Observe that user able to type into this text box.
6. Add image og size 58X58 into URL Type icon.
7. Now type into URL Schemes text box.

Actual Result: When user adds image and click in URL Schemes text box, unable to type in that text box.

Expected Result: If user has added image in URL Type, user should be able to type into URL schemes.

Supplement info:
http://screencast.com/t/DIwjd6uL5

Environment details:
All Mac
X.S 4.1.9(build 6)
X.iOS 6.4.4-12
Mono 3.2.2

Regression Status:
Same behavior happening with Stable X.S 4.0.10(build 7) but we are not sure it has worked on previous build or not.
Comment 1 Jeffrey Stedfast 2013-08-29 22:52:20 UTC
This *may* be fixed in git master (can't build to test, though).
Comment 2 Saurabh 2013-09-05 14:41:54 UTC
We have checked this issue with latest build XamarinStudio-4.1.10(Build 11)

Now, after added image in URL Type, user is able to type into URL schemes.

Screwencast: http://www.screencast.com/t/H0yl7lL9v

Environment details:
All mac
XamarinStudio-4.1.10(Build 11)-cfb240774f7c2f0bcc1dde16ed51725ef8780a11
Mono 3.2.2 ((no/a0fc6ba)
Xamarin.iOS Version: 6.9.6.0
Xcode 4.6.3 (2068)

Hence, closing this issue.