Bug 14257 - Problems with code drop downs (class/methods)
Summary: Problems with code drop downs (class/methods)
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.12
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-08-26 22:50 UTC by Neal
Modified: 2013-08-28 08:03 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Neal 2013-08-26 22:50:28 UTC
I have two issues with the drop downs above the code window, this is using a non-retina MacBook Pro, not sure if it happens on my retina MBP, will have to check.

1) Sorting.  It seems like the drop downs such as for properties/methods does not always sort, I don't understand the ordering at times

2) If I drop down the list control and use the finger drag on the center of the magic mouse (like scroll wheel) to advance the list, the mouse has alignment issues, i.e. the arrow has to be almost to the item above the one I want to click.  you can see this by moving the mouse pointer up, the highlight lags the pointer quite a bit
Comment 1 Mike Krüger 2013-08-28 08:03:11 UTC
Should be fixed in 4.1.10