Bug 14237 - Getting exception "OpenTK.Platform.Android.EglException" for Android sample 'GLTriangle20' on emulators
Summary: Getting exception "OpenTK.Platform.Android.EglException" for Android sample '...
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.8.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2013-08-26 08:54 UTC by narayanp
Modified: 2013-08-26 10:32 UTC (History)
0 users

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description narayanp 2013-08-26 08:54:50 UTC
Steps to reproduce this issue:
1. Open android  sample 'GLTriangle20'.
2. Debug or run the sample on Emulator.

Actual Result: When user debug or run the sample on emulator, it get crashed and throwing exception "OpenTK.Platform.Android.EglException" on all emulators except API15(x86) and API17(x86). While on physical devices this is working fine.

Expected Result: Application should work on all emulators.

Supplement info:
Error Output:
https://gist.github.com/saurabh360/53a641591ab9e66748d6
Application Output: https://gist.github.com/saurabh360/39d416365b665f73488b
Android Log: https://gist.github.com/saurabh360/e14ef3a8335602a000a0
Logcat: https://gist.github.com/saurabh360/43eef703d77e6b836aaf

Device Info:
All Emulators excepts API15(x86) and API17(x86)

App Info: 
monodroid sample-master/GLTriangle20 and GLTriangle20-1.0

Environment details:
All Mac and Windows
X.S 4.1.9(build 9)
Mono 3.2.2
X.Android 4.8.2-54

Regression Status:
same behavior happening with stable MFA 4.8.0-13. But we are sure it has worked before.
Comment 1 narayanp 2013-08-26 09:42:25 UTC
Same issue appearing with VS 2012/2010 as well.
Comment 2 Peter Collins 2013-08-26 10:32:30 UTC
Normal android emulators only support GLES 1.1, and this sample utilizes 2.0. To test GLES 2.0 samples on emulators you will need to enable the "Use Host GPU" option in the emulator settings [1]. Please note that is is only available for API 14 emulators or higher.

[1] http://screencast.com/t/GTw3ZABB