Bug 14202 - Android Builds do not work when Parallel builds is enabled in Visual Studio
Summary: Android Builds do not work when Parallel builds is enabled in Visual Studio
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.8.x
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2013-08-23 05:13 UTC by dean.ellis
Modified: 2014-01-13 09:57 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description dean.ellis 2013-08-23 05:13:30 UTC
From Customer case https://xamarin.desk.com/agent/case/44234


"
we had to remove VS parallel build (Tools>Options>Projects and solutions>Build And Run>maximum number of parallel projects build set to 1) otherwise we still get error compile once every 2 compilation.
Do you have ideas about that? We would like to use parallel builds again!"

There appears to be an issue where the compilation fails every other attempt when parallel builds is enabled.
Comment 1 Andreas 2013-10-10 05:23:44 UTC
Just wanted to confirm that this is still a problem - we use Xamarin.Android 4.8.1 (latest stable version at the moment) and if we enable parallel builds we encounter problems like 'CS1566: Error reading resource file 'c:\CruiseControl.NET\server\Continuous Integration Build\WorkingDirectory\Temp\Release\Soloplan.InTouch.DataAccess.Properties.Resource.resources' -- 'The system cannot find the file specified. ' in CSC(0, 0)' while building our projects.
Comment 4 dean.ellis 2014-01-13 09:57:41 UTC
This seems to be fixed as part of the fix for #10433. 
I am unable to replicate this error anymore.