Bug 14195 - [iOS] monotouch test- PixelFormatDescriptionTest fails on iOS device
Summary: [iOS] monotouch test- PixelFormatDescriptionTest fails on iOS device
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Pre-release ()
Version: 6.4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: 6.4.x (post async)
Assignee: Sebastien Pouliot
URL:
Depends on:
Blocks:
 
Reported: 2013-08-22 19:38 UTC by GouriKumari
Modified: 2013-08-23 08:54 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 Sebastien Pouliot 2013-08-22 20:26:35 UTC
You mean building from a Lion machine fails, while it works on ML ? with the same device, same XiOS and unit tests revision ?

That could be because it uses a different, older Xcode, but in general it should not matter. Can you please paste the start of the logs ? (or just re-run this test).

I'll also try it on my own Lion computer. I don't recall a failure but that test was modified recently IIRC.
Comment 2 Sebastien Pouliot 2013-08-22 20:53:59 UTC
monotouch-tests runs fine on my iPod Touch (4th gen).

> Device: XQAiPodTouch 6.1.4

Sure it's 6.1.4 ? I have 6.1.3 and it says there's no update available.
Comment 4 Sebastien Pouliot 2013-08-23 08:54:23 UTC
Ok, it's a value not available in iOS5.1 (not a bug).

We do not mark our enums values with [Since] and Apple provides names/values that it does not really support, e.g.

> CoreVideo does not provide support for all of these formats; this list just defines their names.

I changed the test to use another value (which is also available under 5.1).

Fixed master / 27fdbc4cdbbf966deb103834b42b4c7ab717594b