Bug 14137 - Xamarin Studio don't start in mac os x 10.6.8
Summary: Xamarin Studio don't start in mac os x 10.6.8
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Runtime
Classification: Mono
Component: packaging ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 13967 14760 ()
Depends on:
Blocks:
 
Reported: 2013-08-21 08:14 UTC by Yaroslav
Modified: 2014-01-17 14:54 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
xamarin studio crash report (27.99 KB, text/plain)
2013-08-21 08:25 UTC, Yaroslav
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Yaroslav 2013-08-21 08:14:32 UTC
I'm truing to run Xamarin Studio at Mac OS X 10.6.8 with X11 2.3.6
I'm drag-n-drop it into /Application directory and run it but it doesn't run with following crash report:

http://pastebin.com/bXjDpuqx

Same result with MonoDevelop 4.0.12 (Stable) and MonoDevelop 4.1.9 (Alpha Release)

Does it incompatible with Mac OS X 10.6.8?
Comment 1 Yaroslav 2013-08-21 08:25:39 UTC
Created attachment 4684 [details]
xamarin studio crash report
Comment 2 Mikayla Hutchinson [MSFT] 2013-08-21 15:19:26 UTC
Mono 3.x does not support MacOS 10.6, and XS 4.0.12 requires Mono 3.x.

We should bump the min OS version in our Info.plist.
Comment 3 Yaroslav 2013-08-21 16:29:37 UTC
I believe it must be noted in documentation. Do i need to file additional ticket in documentation component?

Is it possible to run older version under 10.6.8?

Which min version mono 3.x support?
Comment 4 Jeffrey Stedfast 2013-08-21 20:02:50 UTC
The goal should be to fix Mono 3.0 to work in 10.6.8
Comment 5 Cody Russell 2013-08-26 15:55:57 UTC
*** Bug 13967 has been marked as a duplicate of this bug. ***
Comment 6 Zoltan Varga 2013-09-16 07:12:04 UTC
*** Bug 14760 has been marked as a duplicate of this bug. ***
Comment 7 Max 2013-09-18 07:56:30 UTC
sigh ! So , there is no plan to fix it ?
Comment 8 Max 2013-09-28 15:39:35 UTC
Could be interesting a bit of transparency about Mono & Xamarin stuff .
Comment 9 Rodrigo Kumpera 2014-01-17 14:54:04 UTC
We officially support our stack running on 10.7 and up. No plans for older systems.