Bug 14134 - Android sample 'AppRestrictions' does not load
Summary: Android sample 'AppRestrictions' does not load
Status: VERIFIED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.8.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2013-08-21 06:10 UTC by narayanp
Modified: 2013-11-19 08:42 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description narayanp 2013-08-21 06:10:16 UTC
Steps to reproduce:
1. Open android sample 'AppRestrictions'

Actual result: Application does not load in X.S, Getting 'Project does not support framework'MonoAndroid,Version=v4.3'. While application loads in VS successfully.

Expected result: Application should load in X.S

Supplement info:
http://screencast.com/t/VI3rWX0Q3f

Environment details:
All Mac and Windows
X.S 4.0.11(build 7)
Mono 3.2.2-0
X.Android 4.8.2-54

Regression Status:
Same behavior seen with X.Android 4.8.0-13
Comment 1 narayanp 2013-08-21 06:15:21 UTC
Same issue happening with android sample 'BasicMediaRouter'
Comment 2 narayanp 2013-08-21 06:49:45 UTC
Same issue appearing for following samples:

BorderlessButton
BluetoothLeGatt
Contactables
CustomChoiceList
DoneBar
Comment 3 PJ 2013-08-21 10:28:26 UTC
Ahh, so this issue is caused by the fact that we're running on XS 4.0.12.

These samples are set to Target Framework 4.3, so we'll need to run with the Alpha XS.

Sorry for the confusion.
Comment 4 Rodrigo Kumpera 2013-09-13 14:33:19 UTC
CC'ing Bryan as he's hitting this issue as well.
Comment 6 Akhilesh kumar 2013-11-19 08:42:58 UTC
Today we have checked this issue with following builds :

XS 4.2.1 (build 4)
X.Android 4.10.01073

As per comment 1, now we are able to deploy this application on Android emulator/Device of 4.3.

Hence closing this issue.