Bug 141 - mdtool is not make friendly
Summary: mdtool is not make friendly
Status: REOPENED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 2.4.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2011-08-01 22:05 UTC by Rodrigo Kumpera
Modified: 2016-10-24 15:19 UTC (History)
4 users (show)

Tags: mdtool
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 141 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
REOPENED

Description Rodrigo Kumpera 2011-08-01 22:05:47 UTC
mdtool returns zero if it fails to load the project file. This completely breaks failure detection if used from a makefile.

BTW, can it feature version strings with a --version CLI option, please?
Comment 1 Lluis Sanchez 2011-08-16 11:23:38 UTC
Which kind of load error are you getting?
Comment 2 Rodrigo Kumpera 2011-08-16 13:35:11 UTC
I found this issue while trying to build monotouch without the mac addin installed.

mdtool would not resolve the kind of project, failing to build but returning zero.

To repro this, remove the mac addin and try to build monotouch/tools/activation.
Comment 3 Marius Ungureanu 2013-11-23 09:19:42 UTC
What is the status on this?
Comment 4 xamarin-release-manager 2015-12-01 19:08:18 UTC
Fixed in version 6.0.0.2077 (roslyn)

Author: Andreas Weizel
Commit: fe6fb675bf88b5f44e055505caf59640d446422c (icsharpcode/RefactoringEssentials)
Included in Commit: bd975bf2f2bbff9e80eb21e6343e83a710d0fe83 (mono/monodevelop)
Comment 5 Marius Ungureanu 2015-12-01 20:22:13 UTC
Nope. This is not the fix.