Bug 14094 - VS2012 tells me no update, VS2010 says there is one
Summary: VS2012 tells me no update, VS2010 says there is one
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.3.x
Hardware: PC Windows
: Highest major
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-08-19 17:14 UTC by James Clancey
Modified: 2013-10-04 17:56 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description James Clancey 2013-08-19 17:14:32 UTC
I am unable to update using VS2012, but when I launch VS2010 the updater pops up instantly and says I need to update. This happens on stable and Alpha channels.
Comment 1 Dominique Louis 2013-08-20 08:30:55 UTC
Clancey,
  I've just tested this using 1.5 and it pops up for both Android and iOS in VS2012.

Any other info you can provide to repro?
Comment 2 Miguel de Icaza [MSFT] 2013-08-20 10:51:42 UTC
According to PJ this is one of the known issues related to our upgrading.

We believe this is an issue with our existing pipeline to upgrade due to the 3 ring-circus that are our shared extension, iOS extension and Android extension.
Comment 5 James Clancey 2013-08-20 12:01:49 UTC
It seems to be working now that I am on alpha.
Comment 6 Dominique Louis 2013-08-20 12:05:24 UTC
James just for clarity, could you confirm if the popup occured while opening a project or via the Tools->Options->Xamarin->iOS page?
Comment 7 James Clancey 2013-08-20 12:15:49 UTC
I was on Alpha, I switched it to stable in the tools. I then restarted vs and reopened my project. At that point it prompted me me to upgrade to stable.
Comment 8 Peter Collins 2013-10-04 17:56:38 UTC
Can't reproduce on the latest from 1.6, there have been quite a few changes to the updater and I'm assuming this will be resolved as a result. Comment #6 on Bug #13643 implies that the related ui issue has been resolved.