Bug 14064 - [VS]Getting build error or Mobile-android sample 'SoMA'
Summary: [VS]Getting build error or Mobile-android sample 'SoMA'
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.8.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2013-08-19 04:02 UTC by Prashant manu
Modified: 2013-08-20 14:09 UTC (History)
0 users

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Prashant manu 2013-08-19 04:02:16 UTC
Steps to reproduce:
1. open mobile android sample 'SoMA' in VS
2. Build the sample

Actual Result: Application giving build error in VS. This is the gist of build output: https://gist.github.com/AkhileshKumar01/0718149bc9a50b6c3a5b

This one builds successfully in XS.

Expected Result: Application should build successfully in VS.

Environment details:
All Windows
VS 2012/2010
Xamarin.Android 4.8.2-54

App Info:
Mobile Samples/SoMA for Android

Regression Status:
We are seeing same behavior with stable X.Android 4.8.0-13 but we are not sure it has worked before on previous builds or not.
Comment 1 Peter Collins 2013-08-20 14:09:41 UTC
I am able to build and deploy the Android_VisualStudio project in  the SoMA_VisualStudio solution. The iOS project is set as the "StartUp" project which can throw off deployment if you just attempt to press the Start or Start Debugging button.

I was able to deploy the android project from VS by right clicking on the Android_VisualStudio project doing the following:
1) Set as StartUp Project
2) Select Deploy
3) After you see the "Deploy Succeeded" text in the bottom left corner of the IDE, you can start debugging the solution by pressing the start button.

http://screencast.com/t/AkZf9Vzn

Please reopen this bug if you are still unable to deploy this project to device after following the above steps.