Bug 14048 - Application Icon missing - and no warning when publishing
Summary: Application Icon missing - and no warning when publishing
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2013-08-16 17:34 UTC by Neal
Modified: 2016-08-03 15:23 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshots (20.56 KB, application/octet-stream)
2013-08-16 17:34 UTC, Neal
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Neal 2013-08-16 17:34:32 UTC
Created attachment 4654 [details]
screenshots

Hello,

I'm using the Alpha as I need 4.3 support immediately, I'm using version 4.8.02054.  This is the second time I've seen my application icon property go missing in the design time properties screen AFTER I find out from uploading an APK to the Google Play store and it tells me the icon is not specified.  

1) Xamarin.Android should not allow a build to be packaged if this icon is not specified.  Don't let me get to Google Play with it missing esp if they are checking for it

2) Why is it getting removed from my manifest?  This was set the last update I pushed, today it went missing again.

FYI

See attachments.
Comment 1 dean.ellis 2013-08-19 05:42:38 UTC
I have replicated this issue. A fix should make it into the next alpha release. 
Thanks for reporting it.