Bug 14039 - Cannot build basic android app template with 4.8.2
Summary: Cannot build basic android app template with 4.8.2
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.8.x
Hardware: PC Mac OS
: Normal enhancement
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2013-08-16 14:33 UTC by Rodrigo Kumpera
Modified: 2015-07-31 11:33 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Rodrigo Kumpera 2013-08-16 14:33:19 UTC
If I create a project template and try to deploy it to the x86 samsung tablet I get the following error.

I have manually uninstalled all user packages on the device before doing this.


Deploy to Device tab in Xamarin Studio:


Detecting installed packages

Removing old runtime

Installing shared runtime

Installing platform framework

Installing application on device

Synchronizing assemblies

Deployment failed because the FastDev assembly directory could not be created.

Deployment failed. FastDev directory creation failed.



Device logcat:

E/ActivityThread( 1213): Service com.android.exchange.ExchangeService has leaked ServiceConnection com.android.emailcommon.service.ServiceProxy$ProxyConnection@212f5310 that was originally bound here
E/ActivityThread( 1213): android.app.ServiceConnectionLeaked: Service com.android.exchange.ExchangeService has leaked ServiceConnection com.android.emailcommon.service.ServiceProxy$ProxyConnection@212f5310 that was originally bound here
E/ActivityThread( 1213): 	at android.app.LoadedApk$ServiceDispatcher.<init>(LoadedApk.java:974)
E/ActivityThread( 1213): 	at android.app.LoadedApk.getServiceDispatcher(LoadedApk.java:868)
E/ActivityThread( 1213): 	at android.app.ContextImpl.bindService(ContextImpl.java:1757)
E/ActivityThread( 1213): 	at android.app.ContextImpl.bindService(ContextImpl.java:1746)
E/ActivityThread( 1213): 	at android.content.ContextWrapper.bindService(ContextWrapper.java:480)
E/ActivityThread( 1213): 	at com.android.emailcommon.service.ServiceProxy.setTask(ServiceProxy.java:158)
E/ActivityThread( 1213): 	at com.android.emailcommon.service.ServiceProxy.setTask(ServiceProxy.java:146)
E/ActivityThread( 1213): 	at com.android.emailcommon.service.AccountServiceProxy.restoreAccountsIfNeeded(AccountServiceProxy.java:135)
E/ActivityThread( 1213): 	at com.android.exchange.ExchangeService$11.run(ExchangeService.java:4575)
E/ActivityThread( 1213): 	at com.android.emailcommon.utility.Utility$2.doInBackground(Utility.java:986)
E/ActivityThread( 1213): 	at com.android.emailcommon.utility.Utility$2.doInBackground(Utility.java:983)
E/ActivityThread( 1213): 	at android.os.AsyncTask$2.call(AsyncTask.java:287)
E/ActivityThread( 1213): 	at java.util.concurrent.FutureTask.run(FutureTask.java:234)
E/ActivityThread( 1213): 	at android.os.AsyncTask$SerialExecutor$1.run(AsyncTask.java:230)
E/ActivityThread( 1213): 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1080)
E/ActivityThread( 1213): 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)
E/ActivityThread( 1213): 	at java.lang.Thread.run(Thread.java:856)


About Xamarin Studio:

Xamarin Studio
Version 4.1.9 (build 6)
Installation UUID: 57aa7576-8069-4247-ba69-f1117c576954
Runtime:
	Mono 3.2.1 ((no/f3f789e)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302010001

Xamarin.Android
Version: 4.8.2 (Business Edition)
Android SDK: /Users/kumpera/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
Java SDK: /usr
java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

Apple Developer Tools
Xcode 4.6.3 (2068)
Build 4H1503

Xamarin.Mac
Xamarin.Mac: 1.4.22

Xamarin.iOS
Version: 6.4.1.1 (Business Edition)
Hash: 5a0fe54
Branch: 
Build date: 2013-30-07 08:24:03-0400

Build Information
Release ID: 401090006
Git revision: 123fc693ab9ba2690f93fcfe2cd3499335049ff4
Build date: 2013-08-06 15:11:38+0000
Xamarin addins: ad4a498b75333e43547e87574c1ec8c7cae05de0

Operating System
Mac OS X 10.8.3
Darwin dynamic-092.bos.xamarin.com 12.3.0 Darwin Kernel Version 12.3.0
    Sun Jan  6 22:37:10 PST 2013
    root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
Comment 1 Jonathan Pryor 2015-07-31 09:06:07 UTC
Peter: Is this still a problem?
Comment 2 Peter Collins 2015-07-31 11:33:20 UTC
I'm unable to reproduce this using the x86 Samsung Galaxy Tab 3 with XA 5.1.5.

There is a seemingly related bug with fast dev deployment to certain x86 emulators in bug #26311.