Bug 14009 - "Go to base symbol" should open assembly browser
Summary: "Go to base symbol" should open assembly browser
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: unspecified
Hardware: PC Linux
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-08-15 14:10 UTC by Andres G. Aragoneses
Modified: 2013-08-16 00:39 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andres G. Aragoneses 2013-08-15 14:10:23 UTC
Steps to reproduce:
1. Have a class Foo in a library, which defines a virtual method Bar().
2. Create a project inside MonoDevelop, link to the library mentioned above (to its binary).
3. Create a class Baz which inherits from Foo, which has a method that overrides Bar ().
4. Right-click on the method's name mentioned in step 3.
5. Click on "Go to Base Symbol".

Current results:
Nothing happens.

Expected results:
Should open class Foo, method Bar() in assembly browser.
Comment 1 Mike Krüger 2013-08-16 00:39:06 UTC
fixed