Bug 13991 - Go to declaration does not go to correct location in file
Summary: Go to declaration does not go to correct location in file
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-08-14 21:46 UTC by Mikayla Hutchinson [MSFT]
Modified: 2014-01-27 09:45 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mikayla Hutchinson [MSFT] 2013-08-14 21:46:28 UTC
A user in the forums reports "I am being taken to the wrong position in the file on a regular basis."

http://forums.xamarin.com/discussion/6874/go-to-declaration-broken#latest

I have been seeing this too.
Comment 1 Mike Krüger 2013-08-15 00:35:31 UTC
It's broken in 4.0.x - I found another possible cause in master. 
But it should generally work in master - I could need more info if it doesn't work there.

(Our file open code is quite complex :/ )
Comment 2 Sadik Ali 2014-01-27 09:45:10 UTC
I have verified this and this is working. hence I marked with status verified:

Refer screen cast: 
Checked With: http://screencast.com/t/LMIa3YwXNSk 

Xamarin Studio
Version 4.2.3 (build 154)

Build Information
Release ID: 402030154
4dca4a28d7ecc2c4df8a4d58e74b8902d0283b53
Xamarin addins: cc120a6f639fa6649aa4d23a0f0e7c5701134047
    
Xamarin.Android
Version: 4.13.0

Please let me know if you have any suggestion.