Bug 13921 - Localized C# Resources not included in Release Build
Summary: Localized C# Resources not included in Release Build
Status: RESOLVED DUPLICATE of bug 13665
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 6.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-08-12 10:43 UTC by MBI
Modified: 2013-08-13 04:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 13665

Description MBI 2013-08-12 10:43:47 UTC
I'm working on the iOS portion of a cross-platform project. In a shared assembly we have several localized resources in classic .resx files.

When i compile the solution i can find the primary assembly and its localized resource files in the solution output folder like this:
MyCompany.MyProject.Shared.dll
de-DE/MyCompany.MyProject.Shared.resources.dll

When i package and deploy such debug build all required files get bundled into the app and at runtime everything works as expected.
When i package and deploy a release build the localized resources are not getting bundled and thus no localized resources are available at runtime.

I believe this used to work with older versions of Xamarin Studio.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-08-13 04:27:03 UTC
This should be fixed in Xamarin.iOS 6.4.2.

*** This bug has been marked as a duplicate of bug 13665 ***