Bug 13899 - Opening iOS Project After 4.0.12 Update Causes Xamarin Studio To Close
Summary: Opening iOS Project After 4.0.12 Update Causes Xamarin Studio To Close
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-08-10 07:25 UTC by Brian
Modified: 2013-08-26 21:53 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Bug Report (79.58 KB, text/plain)
2013-08-10 15:09 UTC, Brian
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Brian 2013-08-10 07:25:59 UTC
After upgrading to Xamarin 4.0.12 on Max OSX 10.8, one of my projects now suddenly closes.  This project has mostly iOS components within it.  When Xamarin Studio opens, I select the project, but it does not fully load the  project before it crashes, and gives the "report this error to apple" with the option to restart.  I have another project with iOS components and that works fine.
Comment 1 Mikayla Hutchinson [MSFT] 2013-08-10 13:15:29 UTC
Can you please attach the crash log from the details section of the crash reporting dialog?
Comment 2 Brian 2013-08-10 15:09:16 UTC
Created attachment 4601 [details]
Bug Report
Comment 3 Mikayla Hutchinson [MSFT] 2013-08-10 16:09:14 UTC
This is a JIT crash.
Comment 4 Brian 2013-08-10 22:33:10 UTC
OK, so what can I do to resolve it?  It only happens for one project and only started happening after upgrading...
Comment 5 Zoltan Varga 2013-08-12 07:17:47 UTC
Can you attach the project file which causes the problem ?
Comment 6 Brian 2013-08-26 21:53:26 UTC
Seems to be working now.