Bug 13848 - Majuscule Key on Microsoft Natural Keybord mis-interpreted
Summary: Majuscule Key on Microsoft Natural Keybord mis-interpreted
Status: CLOSED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.10
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: (C8)
Assignee: Cody Russell
URL:
Depends on:
Blocks:
 
Reported: 2013-08-08 04:50 UTC by Antoine Cailliau
Modified: 2016-06-08 11:15 UTC (History)
4 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:


Attachments
PList editor (32.31 KB, image/png)
2013-08-08 04:50 UTC, Antoine Cailliau
Details
Weird symbol (4.14 KB, image/png)
2013-08-08 04:51 UTC, Antoine Cailliau
Details
PList file (1.53 KB, application/octet-stream)
2013-08-08 04:51 UTC, Antoine Cailliau
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Antoine Cailliau 2013-08-08 04:50:50 UTC
Created attachment 4580 [details]
PList editor

When using Xamarin Studio (and only this application) the majuscule key is probably misinterpreted. It adds an extra weird symbol (see screenshot)

When editing fields like plist file this makes the plist wrong format and cause crash of the application (see attached plist for example, edited with xamarin studio and corresponding screenshot. Identifier is the field to look at.)

When creating a new class, it also misinterpret that (even if not displayed). For example, the name of the class become My_Class instead of MyClass.
Comment 1 Antoine Cailliau 2013-08-08 04:51:08 UTC
Created attachment 4581 [details]
Weird symbol
Comment 2 Antoine Cailliau 2013-08-08 04:51:40 UTC
Created attachment 4582 [details]
PList file
Comment 3 Mikayla Hutchinson [MSFT] 2013-08-08 13:49:07 UTC
What is the "Majuscule" key? What keyboard layout are you using?
Comment 4 Antoine Cailliau 2013-08-19 02:32:22 UTC
Left or right Maj key (the one with the up arrow)

I'm using the layout "French - Microsoft".
Comment 5 Cody Russell 2013-09-16 16:53:54 UTC
Hi Antoine,

I've been working on fixing some input-related bugs.  Would you mind testing this build for me and letting me know if it helps any with this issue?

https://dl.dropboxusercontent.com/u/5179007/libgdk-win32-2.0-0.dll

Put this into C:\Program Files (x86)\GtkSharp/2.12\bin

(backup the file in that directory first, just in case)

 / Cody
Comment 6 Cody Russell 2013-09-16 17:04:59 UTC
I'm sorry, this is reported as a Mac issue and the input issues I've been working on were Win32.  So please ignore my last comment.
Comment 7 Antoine Cailliau 2013-09-18 03:54:11 UTC
Since my keyboard is a MS one, it might have an impact. Do you have a binary I can test?
Comment 8 Antoine Cailliau 2013-09-23 10:46:44 UTC
Apparently, last update resolved the bug.
Comment 9 narayanp 2014-01-24 06:54:30 UTC
As per Antoine's comment 8, this issue is resolved.

Hence closing this issue.
Comment 10 Antoine Cailliau 2015-09-23 04:48:17 UTC
Bug reappeared in latest update of Xamarin Studio (5.10, build 799) and it's extremely painful to create new files.
Comment 11 Antoine Cailliau 2015-09-23 06:43:04 UTC
I installed the preview of Xamarin Studio 6 (build 1271) and the problem is, as expected, there as well. (likely to be in gdk?)
Comment 14 Antoine Cailliau 2016-03-04 07:45:07 UTC
Bug is no longer present in Xamarin Studio 6.0 Build 4520.
Comment 15 Akhilesh kumar 2016-06-08 11:15:00 UTC
As per comment 14 this issue is no longer present with XS 6.0(build 4520). So I am closing this issue.

Thanks!