Bug 13835 - Android addin reports nasty error when SDK isn't installed
Summary: Android addin reports nasty error when SDK isn't installed
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
: 13862 ()
Depends on:
Blocks:
 
Reported: 2013-08-07 17:26 UTC by Aaron Bockover [MSFT]
Modified: 2016-08-03 15:37 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Aaron Bockover [MSFT] 2013-08-07 17:26:36 UTC
When the Xamarin.Android framework/SDK is not installed, and -v (verbose) is used with mdtool, a misleading/pointless error is always reported:

ERROR [2013-08-07 17:23:35Z]: ANDROID: Error finding Xamarin.Android SDK
System.ArgumentException: Invalid sdk path 
  at Xamarin.AndroidTools.MonoDroidSdkBase.Initialize (System.String mfaSdkPath, System.String mfaFrameworkPath) [0x0009d] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.10-branch/f324e215/source/md-addins/MonoDevelop.MonoDroid/external/androidtools/Xamarin.AndroidTools/Sdks/MonoDroidSdkBase.cs:70 
  at Xamarin.AndroidTools.MonoDroidSdk.Refresh (System.String mfaSdkPath, System.String mfaFrameworkPath) [0x00044] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.10-branch/f324e215/source/md-addins/MonoDevelop.MonoDroid/external/androidtools/Xamarin.AndroidTools/MonoDroidSdk.cs:120 

Since the addin is always bundled with XS, and a user is certainly not required to have the Xamarin.Android product installed, this message should *never* be displayed. It certainly shouldn't be an error log-level.

It shows up in build logs, and that's not good. If the framework isn't installed, it's not installed. That's not an error, or a warning, or anything.
Comment 3 Mikayla Hutchinson [MSFT] 2013-08-07 21:48:02 UTC
Should be fixed.
Comment 4 Mikayla Hutchinson [MSFT] 2013-08-08 16:00:05 UTC
*** Bug 13862 has been marked as a duplicate of this bug. ***