Bug 13834 - Xamarin Studio 4.0.11 on Windows build fails to find files in referenced projects
Summary: Xamarin Studio 4.0.11 on Windows build fails to find files in referenced proj...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 4.0.10
Hardware: Macintosh Mac OS
: Highest critical
Target Milestone: master
Assignee: Lluis Sanchez
URL:
: 13855 ()
Depends on:
Blocks:
 
Reported: 2013-08-07 17:17 UTC by CraigD
Modified: 2013-08-08 15:24 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot showing error messages (320.38 KB, image/png)
2013-08-07 17:17 UTC, CraigD
Details
build output (8.70 KB, application/octet-stream)
2013-08-07 18:18 UTC, CraigD
Details
actual project/solution exhibiting the bug (40.56 KB, application/x-zip-compressed)
2013-08-07 18:20 UTC, CraigD
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description CraigD 2013-08-07 17:17:37 UTC
Created attachment 4571 [details]
screenshot showing error messages

Android project (Tasky example) that previously compiled on Xamarin Studio for Windows.
Compilation fails in latest release. It seems like the compiler is ignoring the BuildAction:AndroidResource

Changing *JUST* /Resources/values/Strings.xml to BuildAction:EmbeddedResource fixes the build.




Xamarin Studio
Version 4.0.11 (build 6)
Installation UUID: e7a2cc79-136b-42eb-b6a4-7122834eabb7
Runtime:
	Microsoft .NET 4.0.30319.17929
	GTK 2.24.13
	GTK# (2.12.0.0)

Xamarin.Android
Version: 4.8.0 (Business Edition)
Android SDK: C:\Users\craigdunn\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.2   (API level 17)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode, sharing)

Build Information
Release ID: 400110006
b8a862fc80adef69bb383dd305619186da9e1f9b
Build date: 2013-07-31 07:16:33Z
Xamarin addins: e0bfb020a2d4ed62aadd4d6f40bd83dcbac98ae3

Operating System
Windows 6.2.9200.0 (64-bit)
Comment 1 Mikayla Hutchinson [MSFT] 2013-08-07 17:49:48 UTC
In future could you attach the actual build output, not a screenshot?
Comment 2 CraigD 2013-08-07 18:18:57 UTC
Created attachment 4572 [details]
build output

of course, sorry!
Comment 3 CraigD 2013-08-07 18:20:47 UTC
Created attachment 4573 [details]
actual project/solution exhibiting the bug
Comment 4 Mikayla Hutchinson [MSFT] 2013-08-07 18:50:44 UTC
This was a regression introduced by the fix for https://bugzilla.xamarin.com/show_bug.cgi?id=1077. The commits have been reverted and a hotfix will be released soon.
Comment 5 Mikayla Hutchinson [MSFT] 2013-08-08 15:24:55 UTC
*** Bug 13855 has been marked as a duplicate of this bug. ***