Bug 13768 - FastCGI Server4 v3.0.11 - applications don't work past 1 level deep
Summary: FastCGI Server4 v3.0.11 - applications don't work past 1 level deep
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: other ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-08-05 22:38 UTC by bfreshour
Modified: 2013-12-05 14:40 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 13768 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description bfreshour 2013-08-05 22:38:33 UTC
This works: http://coh2.us.to/razoronmono/

This doesn't: http://coh2.us.to/apps/razoronmono/

All code in the subdirectories is the same...

applications="/:/srv/www,/razoronmono:/srv/www/razoronmono,/apps/razoronmono:/srv/www/apps/razoronmono"

nginx config: location / {

    }
    location /razoronmono {
            include /etc/nginx/fastcgi_params;
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_index /;
    }

    location /apps/razoronmono {
            include /etc/nginx/fastcgi_params;
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_index /;
    }
    location ~ \.(aspx|asmx|ashx|asax|ascx|soap|rem|axd|cs|config|dll)$ {
        fastcgi_pass   127.0.0.1:9000;
        include        /etc/nginx/fastcgi_params;
    }

I get the following error:

    System.InvalidOperationException Failed to map path '/apps/_ViewStart.cshtml'

    Description: HTTP 500.Error processing request.
Comment 1 Rev 2013-12-05 14:40:17 UTC
I'm having the exact same problem on Ubuntu Trusty using Apache and mod_mono of xsp 3.0.11.