Bug 13737 - autocomplete hangs (F# for Xamarin Studio Development 4.0.4)
Summary: autocomplete hangs (F# for Xamarin Studio Development 4.0.4)
Status: RESOLVED DOWNSTREAM
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-08-04 02:40 UTC by Ashley Towns
Modified: 2016-08-03 15:37 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
resulting log from sending killall -QUIT to XS (105.64 KB, application/octet-stream)
2013-08-04 02:40 UTC, Ashley Towns
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DOWNSTREAM

Description Ashley Towns 2013-08-04 02:40:42 UTC
Created attachment 4536 [details]
resulting log from sending killall -QUIT to XS

When trying to autocomplete something i get a beachball and a 4-5 second lag before the autocomplete window appears
this only happens for certain things ie (this. -> [beachball] but 'GridView. ->' is fine)

Tested on stable and beta, happens instantly after a fresh start (rMBP, OS X 10.8.4)

Doesn't happen on a C# based android project

I've attached a log with the stacktrace while beacbballing

I'm guessing its possibly related the build warning i get as well:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Warning: Failed to read '/Library/Frameworks/Xamarin.Android.framework/Versions/Current/lib/mono/2.1/FSharp.Core.dll' with debugging symbols. Retrying to load it without it. Error details are logged below. (xxx.Android)

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Warning: System.ArgumentOutOfRangeException: Non-negative number required.
Parameter name: srcOffset
  at System.Buffer.BlockCopy (System.Array src, Int32 srcOffset, System.Array dst, Int32 dstOffset, Int32 count) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.PE.Image.GetDebugHeader (System.Byte[]& header) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.ModuleDefinition.GetDebugHeader (System.Byte[]& header) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.ModuleDefinition.ProcessDebugHeader () [0x00000] in <filename unknown>:0 
  at Mono.Cecil.ModuleDefinition.ReadSymbols (ISymbolReader reader) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.ModuleReader.ReadSymbols (Mono.Cecil.ModuleDefinition module, Mono.Cecil.ReaderParameters parameters) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.ModuleReader.CreateModuleFrom (Mono.Cecil.PE.Image image, Mono.Cecil.ReaderParameters parameters) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.IO.Stream stream, Mono.Cecil.ReaderParameters parameters) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.String fileName, Mono.Cecil.ReaderParameters parameters) [0x00000] in <filename unknown>:0 
  at Mono.Cecil.AssemblyDefinition.ReadAssembly (System.String fileName, Mono.Cecil.ReaderParameters parameters) [0x00000] in <filename unknown>:0 
  at Xamarin.Android.Tuner.DirectoryAssemblyResolver.ReadAssembly (System.String file) [0x00000] in <filename unknown>:0  (xxx.Android)
Comment 1 Ashley Towns 2013-08-04 02:49:06 UTC
Sorry, closer to 10-15 second lag
Comment 2 Mikayla Hutchinson [MSFT] 2013-08-05 15:23:59 UTC
This is an issue in the F# addin, which is a third party addin.

Please report thsi to https://github.com/fsharp/fsharpbinding/issues