Bug 13728 - Cross compiling with mingw32 failing with invalid asm
Summary: Cross compiling with mingw32 failing with invalid asm
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-08-02 17:57 UTC by Micael Dias
Modified: 2015-01-08 05:36 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Micael Dias 2013-08-02 17:57:24 UTC
Hello

I was trying to cross compile mono from linux to windows i486 with mingw-gcc 4.7.2 and I got the following error:

../../../mono/metadata/threads.c:820:2: error: invalid 'asm': invalid expression as operand

I don't know much about assembly, so I cannot help with what might be the error, but it's a single line operation.
Comment 1 Zoltan Varga 2013-08-09 05:24:47 UTC
Could you try again with master ?
Comment 2 Micael Dias 2013-08-09 09:36:49 UTC
Tried with master. This specific error is gone, but now I have another:

  CCLD     monow.exe
ln -sf mono-sgen.exe mono.exe
make[4]: *** No rule to make target `mono-sgen', needed by `mono'.  Stop.
make[4]: Leaving directory `/tmp/mono-build/build-cross-windows/mono/mini'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/mono-build/build-cross-windows/mono/mini'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/mono-build/build-cross-windows/mono'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/mono-build/build-cross-windows'
make: *** [all] Error 2

Maybe I should open another bug?
Comment 3 Zoltan Varga 2015-01-08 05:36:46 UTC
Cross compiling should now work with MXE: http://mxe.cc/