Bug 13665 - Resources generated from RESX files no longer copied to IPA packages
Summary: Resources generated from RESX files no longer copied to IPA packages
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 6.4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
: 13921 ()
Depends on:
Blocks:
 
Reported: 2013-07-31 15:41 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2013-08-13 04:27 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2013-07-31 15:41:26 UTC
Reported on behalf of a user:

We've recently upgraded our development systems with the new Xamarin.IOS and Xamarin Studio.

Our applications are available in 3 languages (English, Dutch (nl) and German(de)).
We use .resx files to make this happen, and this used to work great in the older versions.
It also currently still works when we deploy to a simulator or a device for debugging/release purposes.
However it doesn't work anymore when we try to create an IPA package for external deployments.

When we try to create a distribution package in order to create a .IPA file, the build process fails to add the resource files to the .app folder, so the resource files are absent from the .IPA file too.
The weird thing is that it actually does build and copy the two localized folders (nl and de) to the Distribution bin folder, however these do not get copied to the .app folder.
If we manually add the two folders to the .app folder after the IPA package has been built once, we can press build again and it will include them in the .IPA archive, and it works in all three languages again.
However that does not seem like it's the way it should be done.


### iPhone Distribution
The nl and de folders are present in the top folder, however they are not in the .app folder. Only English (Default) is available once installed on the device. Manually pasting the folders into the .app folder and rebuilding the package leads to it being included in the .ipa package.

### iPhone Debug
Both nl and de folders are present in the top folder and the .app folder, and all languages work in the simulator.

### iPhone Release
Both nl and de folders are present in the top folder and the .app folder, and all languages work in the simulator.

### iPhoneSimulator Debug
Both nl and de folders are present in the top folder and the .app folder, and all languages work in the simulator.


To summarize:
Deployment type        Result
iPhone Distribution    NOT OK
iPhone Debug           OK
iPhone Release         OK
Simulator Debug        OK


## Version information

Xamarin Studio
Version 4.0.10 (build 7)
Runtime:
    Mono 3.2.0 ((no/7c7fcc7)
    GTK 2.24.20
    GTK# (2.12.0.0)
    Package version: 302000000

Apple Developer Tools
Xcode 4.6.3 (2068)
Build 4H1503

Xamarin.iOS
Version: 6.4.0.2 (Business Edition)
Hash: c9f7659
Branch: 
Build date: 2013-18-07 21:36:03-0400

Xamarin.Mac
Xamarin.Mac: Not Installed

Xamarin.Android
Not Installed

Build Information
Release ID: 400100007
Git revision: f324e2154ee86ae1b6b8483392eddbf418e6381b
Build date: 2013-07-20 06:23:58+0000
Xamarin addins: fe4f180e2386eafc00087ef68c3a580cff4a2592

Operating System
Mac OS X 10.7.5
Darwin MacBook-Pro.local 11.4.2 Darwin Kernel Version 11.4.2
    Thu Aug 23 16:25:48 PDT 2012
    root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-07-31 19:32:47 UTC
Can you attach a test project I can use to reproduce this?
Comment 5 Rolf Bjarne Kvinge [MSFT] 2013-08-01 07:39:28 UTC
Fixed. The fix will be included in 6.4.2.

This is related to #13512, the problem is that we don't copy satellite assemblies to the .app in release mode.

monotouch/master-3.0: 7429bb0bfd3f65b0479913a5b5ea708819091461
monotouch/monotouch-6.4-series: 0b8d38f180e8dd356e95c33edec2833f5e8b6056

QA: automated unit test added.
Comment 8 Rolf Bjarne Kvinge [MSFT] 2013-08-13 04:27:03 UTC
*** Bug 13921 has been marked as a duplicate of this bug. ***