Bug 1362 - Allow MonoDevelop to open corrupt UTF8 files so they can be fixed
Summary: Allow MonoDevelop to open corrupt UTF8 files so they can be fixed
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8
Hardware: Macintosh Mac OS
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-08 07:48 UTC by Chris Hardy [MSFT]
Modified: 2011-12-03 14:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case for corrupt UTF8 file (729 bytes, application/zip)
2011-10-08 12:46 UTC, Chris Hardy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Hardy [MSFT] 2011-10-08 07:48:40 UTC
If a user tried to open a invalid UTF8 file, we should offer a fallback which ignores invalid bytes thus 'corrupting' the file a bit but potentially allowing the user to fix the problems. We could even make a backup of the file before we try to fix it up.
Comment 2 Chris Hardy [MSFT] 2011-10-08 12:46:15 UTC
Created attachment 645 [details]
Test case for corrupt UTF8 file
Comment 3 Mike Krüger 2011-11-15 15:33:03 UTC
should be fixed in master.
Comment 4 Dominique 2011-12-03 12:09:07 UTC
Hi I'm running 2.8.2 and this is still and issue. Which build of MonoDevelop is this fixed in? I can supply a .cs file if needed.
Comment 5 Mikayla Hutchinson [MSFT] 2011-12-03 14:20:46 UTC
There has not yet been a release containing the fix, but it should be in the next release.