Bug 13582 - [iOS] BCL System tests crashes on iPodTouch 5.1.1 device
Summary: [iOS] BCL System tests crashes on iPodTouch 5.1.1 device
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 6.4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: 7.2.0 (iOS 7.1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-07-29 18:44 UTC by GouriKumari
Modified: 2016-01-11 16:43 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-07-29 19:44:14 UTC
This looks related to network code in the bcl. Marek, can you have a look?
Comment 2 Marek Safar 2013-07-30 04:56:40 UTC
This looks like some race but don't know why runtime does not show the exception.

Gouri, can you reliably reproduce the issue. Does it fail all the time if you run only failing test 10 times?
Comment 3 GouriKumari 2013-07-30 17:52:52 UTC
Marek, 

I am not able to reproduce this issue reliably. I executed the tests, a couple of times, in the same iPodTouch5.1.1 and each time tests succeeded without any issues.
I checked with both Xamarin.iOS 6.4.0.5.pkg and Xamarin.iOS 6.4.1.1.pkg. 

Test Env:

Xamarin.iOS 6.4.0.5.pkg , 6.4.1.1..pkg
XQAiPodTouch 5.1.1
Comment 4 PJ 2013-11-19 16:44:47 UTC
This bug was targeted for a past milestone, moving to the next non-hotfix active milestone.
Comment 5 Sebastien Pouliot 2014-12-06 11:49:09 UTC
@Gouri does this still happens ? comment #3 makes it sounds like you could not with 6.4+
Comment 6 GouriKumari 2014-12-08 19:44:27 UTC
Retested with Xamarin.iOS: 351c869
Device: iPodTouch5.1.1

Test failed to execute after: UDPClient , but it didn't crash on HttpListener tests. 

Test Log: https://gist.github.com/GouriKumari/248e122276a2cfbaa744

I will verify this bug again and see what cause the device not execute the complete test.
Comment 7 GouriKumari 2016-01-11 16:43:44 UTC
This is an old bug and new bugs related to System test failures are currently open in latest milestones. Hence I am closing this message.