Bug 13557 - Outdated debugger information dialog when starting debugging
Summary: Outdated debugger information dialog when starting debugging
Status: RESOLVED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.1
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-07-29 06:32 UTC by Zoltan Varga
Modified: 2014-02-27 15:05 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Zoltan Varga 2013-07-29 06:32:55 UTC
To reproduce:
- create a console app
- do 'rebuild all' from the menu
- do 'Start Debugging' from the menu

Result: 'Outdated debugging information' dialog every time.

Version info:
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
=== Xamarin Studio ===

Version 4.1.8 (build 8)
Installation UUID: 998c8949-5bf7-49e2-b38b-2ac1ebb72e74
Runtime:
	Mono 3.1.2 ((no/777c482)
	GTK 2.24.20
	GTK# (2.12.0.0)
	Package version: 301020000

=== Xamarin.Android ===

Version: 4.6.0
Android SDK: Not found

=== Apple Developer Tools ===

Xcode 4.6.3 (2068)
Build 4H1503

=== Xamarin.Mac ===

Xamarin.Mac: 1.3.7

=== Xamarin.iOS ===

Version: 6.3.7.232 (Business Edition)

=== Build Information ===

Release ID: 401080008
Git revision: a11bc57dd596420cf5ee8d8f4188f88b98790334
Build date: 2013-07-26 21:37:24+0000
Xamarin addins: 1a18e87a89508acdf8cec3ad46dc5bb3b49791c1
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Comment 1 Jeffrey Stedfast 2013-07-29 11:14:26 UTC
this is a bug in the DotNetProject build logic
Comment 2 Zoltan Varga 2014-02-27 14:06:51 UTC
So this is kinda the expected behavior when the 'build project before running' option is checked off.
Comment 3 Mikayla Hutchinson [MSFT] 2014-02-27 15:05:59 UTC
Nah, it's a bug that it comes up every time. We should use a "FastUpToDateCheck" like VS does. See bug 12951.