Bug 13531 - Actions are not generated/regenerated correctly
Summary: Actions are not generated/regenerated correctly
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: 4.1.9
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2013-07-26 17:24 UTC by Alan McGovern
Modified: 2013-08-07 15:50 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alan McGovern 2013-07-26 17:24:35 UTC
IF you create an action and then create another one, we end up removing the [GeneratedCodeAttribute] attribute from the original action and leaving it in the .designer.cs file.

We need to update the action generation code to work the same way as the outlet generation code.
Comment 1 Alan McGovern 2013-08-07 15:50:41 UTC
Committed