Bug 13507 - INTERNET permission required after 4.8 upgrade
Summary: INTERNET permission required after 4.8 upgrade
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 4.8.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2013-07-26 09:39 UTC by Ben Rogers
Modified: 2014-07-28 16:04 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Ben Rogers 2013-07-26 09:39:41 UTC
After the 4.8 upgrade, I ran our integration tests and encountered an issue when deploying an application. From the Visual Studio Output window:

> Couldn't connect to logcat, GetProcessId returned: 0

From the Android Device Log:

> Trying to initialize the debugger with options: --debugger-agent=
>   transport=dt_socket,loglevel=0,address=127.0.0.1:8885,server=y,
>   embedding=1
> Could not construct a socket for stdout and stderr; does your app
>   have the android.permission.INTERNET permission? Permission denied

Changing the project to require the INTERNET permission does correct the problem. However, I'm reporting the issue because:

1) The error doesn't occur in 4.7--only 4.8. I checked the release notes, but I didn't see any relevant behavioral changes.
2) The error only occurs when building the Release configuration. I'm able to build and deploy a Debug configuration successfully with 4.8.

I'm testing in Visual Studio on Windows 8. and deploying to a Galaxy Nexus emulator using the Intel x86 Atom System Image. The Intel HAXM hypervisor is installed and enabled. GPU emulation is enabled.
Comment 1 Jonathan Pryor 2014-07-28 16:04:28 UTC
The debugger requires the INTERNET permission so that the app can attach to the debugger. The INTERNET permission is only implicitly added in Debug builds; in all other configurations, the INTERNET permission is not added.