Bug 13491 - SIGSEGV when entering a synchronized method
Summary: SIGSEGV when entering a synchronized method
Status: RESOLVED DUPLICATE of bug 13500
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 4.8.x
Hardware: PC Windows
: Highest normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-07-25 22:02 UTC by Jeremy Kolb
Modified: 2013-07-26 16:30 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 13500

Description Jeremy Kolb 2013-07-25 22:02:18 UTC
See http://forums.xamarin.com/discussion/6366/sigsegv-failures-after-xamarin-android-4-8-upgrade

Anytime I get into a method marked with MethodImpl(Synchronized) I get the following:

07-25 14:32:43.787 F/        ( 3641): * Assertion at /Users/builder/data/lanes/monodroid-mlion-monodroid-4.8.0-branch/3f1c339b/source/mono/mono/mini/mini.c:3806, condition `l' not met
07-25 14:32:43.797 E/mono-rt ( 3641): Stacktrace:
07-25 14:32:43.797 E/mono-rt ( 3641): 
07-25 14:32:43.797 E/mono-rt ( 3641):   at <unknown> <0xffffffff>

followed by a 

07-25 14:32:43.797 E/mono-rt ( 3641): =================================================================
07-25 14:32:43.797 E/mono-rt ( 3641): Got a SIGSEGV while executing native code. This usually indicates
07-25 14:32:43.797 E/mono-rt ( 3641): a fatal error in the mono runtime or one of the native libraries 
07-25 14:32:43.797 E/mono-rt ( 3641): used by your application.
07-25 14:32:43.797 E/mono-rt ( 3641): =================================================================
07-25 14:32:43.797 E/mono-rt ( 3641): 

rendering 4.8 unusable.

I've seen this on a Motorola Xoom but haven't tried any other device.  The assertion is always missing one or two stack frames in the trace.  I'm not sure if that's a clue or not.
Comment 1 Zoltan Varga 2013-07-26 02:39:27 UTC
jonp: this was fixed by 180fb9b3f944eef328829d726a3308e2079855eb in mono.
Comment 2 Zoltan Varga 2013-07-26 02:40:53 UTC
And b8c6612c28d843016f9f89a6011d8340edafa77b on mono-3-2.
Comment 3 Jeremy Kolb 2013-07-26 16:30:43 UTC
Duplicate of 13500.

*** This bug has been marked as a duplicate of bug 13500 ***