Bug 13476 - `' is not a valid warning number (CS1904)
Summary: `' is not a valid warning number (CS1904)
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-07-25 13:00 UTC by Todd
Modified: 2013-07-26 05:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot (185.99 KB, image/png)
2013-07-25 13:00 UTC, Todd
Details
Screenshot Showing version 3.2.0 (437.90 KB, image/png)
2013-07-25 17:47 UTC, Todd
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Todd 2013-07-25 13:00:57 UTC
Created attachment 4433 [details]
screenshot

Whine I try to compile .net Nuke, I get `' is not a valid warning number (CS1904) error without line numbers or file.  It compiles without error on my Windows machine with Xamarian.
Comment 1 Marek Safar 2013-07-25 16:27:45 UTC
Please upgrade to Mono 3.2 which should have the issue fixed
Comment 2 Todd 2013-07-25 17:47:36 UTC
Created attachment 4443 [details]
Screenshot Showing version 3.2.0
Comment 3 Todd 2013-07-25 17:48:58 UTC
I am/was using mono 3.2.  Upgraded to the latest Xamarian and Mono before I started project.
Comment 4 Marek Safar 2013-07-26 05:07:40 UTC
Fixed in master & 3.2 branch. As a workaround you can remove spaces in "Ignore warnings" project settings