Bug 13469 - [Windows]Getting 'Fatal error' when user adding breakpoint after adding New function Breakpoint
Summary: [Windows]Getting 'Fatal error' when user adding breakpoint after adding New f...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.1
Hardware: PC Windows
: Normal major
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-07-25 08:11 UTC by Prashant manu
Modified: 2013-11-29 12:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Prashant manu 2013-07-25 08:11:58 UTC
Steps to reproduce this issue:
1. Open or create Android application.
2. Open .cs file.
3. Got to Run->New Function Breakpoint.
4. Provide function name and click OK button.
5. Now try to add breakpoint in .cs file.

Actual Result: Fatal error appears shown in screencast: 
http://screencast.com/t/9SyjHioHl

No Mac this is working fine

Expected result: User should able to create breakpoint in .cs file if user has created a function breakpoint before.

Environment details:
All Windows
X.S 4.1.8(build 1)
Xamarin.Android 4.8.0-13

Regression Status:
We are seeing the same behavior on stable X.S 4.0.9(build 2) and X.S 4.0.10(build 7) but we are not sure weather this was working on previous builds or not.
Comment 1 Prashant manu 2013-07-25 08:16:05 UTC
Error log:
https://gist.github.com/saurabh360/15556b1beebc21bc5e89
Comment 2 Jeffrey Stedfast 2013-07-26 12:23:38 UTC
fixed in git master (4.1.9?)
Comment 3 Atin 2013-11-29 12:20:39 UTC
Today we have checked this issue with following builds:

Environment details:
All Windows
X.S 4.2.2(build 2)
Xamarin.Android 4.10.01073

screencast:http://screencast.com/t/r8Qnjk16mc4W

Now No fatal error is appeared when user adds new function breakpoint.Hence verifying this issue.