Bug 133 - Monodoc does not start up on Lion.
Summary: Monodoc does not start up on Lion.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: PC Linux
: --- enhancement
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2011-08-01 12:42 UTC by Miguel de Icaza [MSFT]
Modified: 2011-08-05 14:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Miguel de Icaza [MSFT] 2011-08-01 12:42:10 UTC
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc: Unhandled Exception: System.IO.DirectoryNotFoundException: Directory '/Users/miguel/Library/Application' not found.
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at System.IO.Directory.GetFiles (System.String path, System.String searchPattern) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at System.IO.Directory.GetFiles (System.String path) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at Monodoc.RootTree.AddSource (System.String sources_dir) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at Monodoc.Driver.LoadTree (System.String basedir, IEnumerable`1 sourcedirs) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at Monodoc.Browser..ctor (System.String basedir, IEnumerable`1 sources, System.String engine) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.057 PM [0x0-0x68e68e].com.novell.monodoc:   at Monodoc.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0 
8/1/11 12:38:37.060 PM com.apple.launchd.peruser.501: ([0x0-0x68e68e].com.novell.monodoc[49133]) Exited with code: 1
Comment 1 Jeffrey Stedfast 2011-08-05 14:18:47 UTC
I guess this one is fixed now