Bug 13291 - Intellisense menu for directives goes off screen
Summary: Intellisense menu for directives goes off screen
Status: VERIFIED DUPLICATE of bug 14003
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-07-17 09:39 UTC by Paul Johnson
Modified: 2014-01-21 08:29 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Menu goes off screen (110.63 KB, image/png)
2013-07-17 09:39 UTC, Paul Johnson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 14003

Description Paul Johnson 2013-07-17 09:39:30 UTC
Created attachment 4359 [details]
Menu goes off screen

using XS 4.1.6 on a Mac (OS X 10.8.4)

While typing in the using directives, the list of available directives goes off screen

The attached image shows what I mean. While this is not a big issue, if there is only 1 item in the menu, it is not visible (for example Newtonsoft shows, but JSon doesn't from the submenu)
Comment 1 Mike Krüger 2013-07-23 02:53:15 UTC
How did you get that - for me the popup window always pops up below at that position.
(since it has a maximum size it can't really grow too big)
Comment 2 Paul Johnson 2013-07-23 05:07:18 UTC
Dunno - it just does it. Is there any sort of debug flag I can issue when starting XS that may help you?
Comment 3 Mike Krüger 2013-07-23 05:56:13 UTC
Are you working in a multi monitor environment ?
Comment 4 Paul Johnson 2013-07-23 06:58:29 UTC
Nope. One monitor - Acer S240HL - nice 24" widescreen job
Comment 5 Mike Krüger 2013-08-19 03:51:57 UTC
duplicate

*** This bug has been marked as a duplicate of bug 14003 ***
Comment 6 Atin 2014-01-21 08:29:15 UTC
Today, we have checked this issue with:

XS 4.2.3(build 146) - 76e7c7f6ca0e59052f2bb29f8179313510977377
ML 10.8.5

Now this issue is not exist, completion window is visible properly in XS.

screencast: http://www.screencast.com/t/FjvILg0K

Hence marking this as Verified