Bug 13224 - Incorrect menu showing with version control and new files not showing
Summary: Incorrect menu showing with version control and new files not showing
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 4.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2013-07-12 21:11 UTC by Paul Johnson
Modified: 2014-01-22 08:04 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Paul Johnson 2013-07-12 21:11:17 UTC
Using 4.1.6 on a mac (Mountain Lion)

If I create a new file in a project under version control, the new file firstly doesn't show in the project viewer unless I do a refresh on the directory it is sitting in and secondly, does not show that it isn't under version control.

Under previous versions, a new file would show with a question mark icon next to it. When I right click on the file and select Version Control I would be offered a menu showing "Add" or "Resolve". This has now changed to be the Update/Review/Commit menu without the file actually being added to svn. The only way to actually add to svn is to do it via the command line.
Comment 1 Marius Ungureanu 2013-07-15 11:14:06 UTC
What version control system is it?

In case it is subversion and you have 1.7 installed, get 4.1.7.
Comment 2 Marius Ungureanu 2013-08-09 12:13:54 UTC
Does this still occur?
Comment 3 Paul Johnson 2013-08-09 12:39:29 UTC
Seems ok with 4.1.9
Comment 4 Marius Ungureanu 2013-08-09 12:54:52 UTC
Okay then, it got fixed. Thanks. :D
Comment 5 Mohit Kheterpal 2014-01-22 08:04:12 UTC
As per Paul's comment 3, its working fine now.

Hence closing this issue.