Bug 13223 - Xam.Studio is having problems with svn
Summary: Xam.Studio is having problems with svn
Status: RESOLVED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 4.1
Hardware: All Mac OS
: --- normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2013-07-12 18:57 UTC by Paul Johnson
Modified: 2013-07-12 21:06 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Paul Johnson 2013-07-12 18:57:06 UTC
Using 4.1.6 on a Mac Mini (Mountain Lion)

Something seems to be up with SVN and the latest Xam.Studio on the Alpha channel

If I create a new file, it is automatically added to source control (at least the version control menu suggests this - normally, it has Add or Resolve, it is now giving the menu that is given after a file has been committed).

If I try to review prior to committing to svn, I'm given the following throwback error report

MonoDevelop.VersionControl.Subversion.SubversionException: Working copy '/Volumes/Developer/Developer/stand/iOS/stand/stand' is too old (format 10, created by Subversion 1.6)
  at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.CheckError (IntPtr error, Nullable`1 allowedError) [0x0009f] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:48 
  at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.CheckError (IntPtr error) [0x00001] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:26 
  at MonoDevelop.VersionControl.Subversion.Unix.UnixSvnBackend.CheckError (IntPtr error) [0x00001] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:171 
  at MonoDevelop.VersionControl.Subversion.Unix.UnixSvnBackend.Status (MonoDevelop.VersionControl.Repository repo, FilePath path, MonoDevelop.VersionControl.Subversion.SvnRevision rev, Boolean descendDirs, Boolean changedItemsOnly, Boolean remoteStatus) [0x00077] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:509 
  at MonoDevelop.VersionControl.Subversion.SubversionBackend.GetDirectoryVersionInfo (MonoDevelop.VersionControl.Repository repo, FilePath sourcepath, Boolean getRemoteStatus, Boolean recursive) [0x00007] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion/MonoDevelop.VersionControl.Subversion/SubversionVersionControl.cs:151 
  at MonoDevelop.VersionControl.Subversion.SubversionRepository.OnGetDirectoryVersionInfo (FilePath sourcepath, Boolean getRemoteStatus, Boolean recursive) [0x0000b] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion/MonoDevelop.VersionControl.Subversion/SubversionRepository.cs:101 
  at MonoDevelop.VersionControl.Repository.GetDirectoryVersionInfo (FilePath localDirectory, Boolean getRemoteStatus, Boolean recursive) [0x0001f] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl/MonoDevelop.VersionControl/Repository.cs:207 
  at MonoDevelop.VersionControl.Views.StatusView.<StartUpdate>m__3 (System.Object ) [0x00019] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.1.6-branch/dc82b708/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl/MonoDevelop.VersionControl.Views/StatusView.cs:415 

By the looks of it, I now need to upgrade the repo to 1.7 to allow me to commit.
Comment 1 Marius Ungureanu 2013-07-12 19:23:49 UTC
If you have subversion library for 1.7, yes you do. If you don't, then respond and I'll take a look at this.
Comment 2 Paul Johnson 2013-07-12 21:06:57 UTC
Ok, I did the upgrade and it worked. I'm going to close this and open a new bug for the UI problem with svn I'm seeing