Bug 13169 - Unable to authorise to higher licence level
Summary: Unable to authorise to higher licence level
Status: RESOLVED FEATURE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-07-11 03:51 UTC by Paul Johnson
Modified: 2016-08-03 15:37 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FEATURE

Description Paul Johnson 2013-07-11 03:51:57 UTC
This is related to #13114

I noticed this while travelling to London on the train. My iOS and Android projects both use JSON.NET and Xamarin.Mobile. When building for iOS, I was informed the problem was down to needing a version greater than starter, the laptop logged into my account and authorised to be business edition.

The Android version didn't give me such an option and I also can't see a way to authorise the copy online or in Xam.Studio.
Comment 1 Mikayla Hutchinson [MSFT] 2013-07-16 16:11:59 UTC
Can you clarify what you mean by "unable"? Are you getting any kind of errors?
Comment 2 Paul Johnson 2013-07-16 16:31:30 UTC
No errors, but then it also doesn't give me the choice to do it. It did for iOS, but not Android
Comment 3 Mikayla Hutchinson [MSFT] 2013-07-16 16:48:53 UTC
This is by design. Activation currently is only triggered if you use a feature that requires the higher editions.
Comment 4 Paul Johnson 2013-07-16 16:59:31 UTC
Problem is that it didn't get triggered on android but the same code on iOS did trigger. Both have and uses JSON.NET and Xamarin.Mobile from the component store which require a higher licence.
Comment 5 Mikayla Hutchinson [MSFT] 2013-07-16 17:15:02 UTC
Maybe it activated automatically and you didn't notice? Check the About dialog.
Comment 6 Paul Johnson 2013-07-17 04:28:28 UTC
About dialog still shows the basic level not business level
Comment 7 Mikayla Hutchinson [MSFT] 2013-07-17 11:18:41 UTC
Maybe the linker made your app small enough that the license wasn't needed yet? If the app builds fine, then I think everything's working as intended.
Comment 8 Paul Johnson 2013-07-17 11:27:09 UTC
It came up with an error about something missing in the obj/debug directory. I had the same error on the iOS version. When I removed the obj/debug problem on iOS, the new licence was requested. I didn't get the same request on Android.
Comment 9 Mikayla Hutchinson [MSFT] 2013-07-17 11:28:23 UTC
What is the error?