Bug 13155 - Activation dialog layout broken
Summary: Activation dialog layout broken
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Activation ()
Version: 1.1.x
Hardware: PC Windows
: High major
Target Milestone: 1.6.x (connection)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2013-07-10 14:51 UTC by Alex Corrado [MSFT]
Modified: 2013-10-31 14:07 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot of activation dialog (183.86 KB, image/png)
2013-07-10 14:51 UTC, Alex Corrado [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alex Corrado [MSFT] 2013-07-10 14:51:29 UTC
Created attachment 4305 [details]
screenshot of activation dialog

In the course of setting up a new Surface Pro, I installed VS2012 Ultimate and downloaded the Xamarin installer, which installed everything else. When I launched VS and created a new iOS project, I got the activation dialog as expected, but the layout was all screwed up (see attached screenshot).

Windows 8
VS 2012 Ultimate
Xamarin.Android   4.6.08007 (0cc7ae3b)
Xamarin.iOS   1.1.200 (7d63692c)
Comment 1 PJ 2013-07-10 17:02:45 UTC
I can reproduce after setting my text display setting setting to 150%. After talking to Alex, it looks like this setting is default on the surface pro.

Here's how to trigger the issue on a normal desktop:

Open an explorer window
Enter 'Control Panel\Appearance and Personalization\Display' into the navigation bar
Choose the 'Larger - 150%' option.
Remove your VS licenses
Start VS and open a project


Hope this helps!


CONFIRMED on a desktop x64 Win 8 Pro machine, with 4.6.8.7 MFA and 1.1.200 MTVS

I'm making this a high major bug due to the fact that this setting is default on the Surface, but we won't have time to deal with it until after 1.4 is out on the current schedule, so 1.6.x milestone.
Comment 2 Dominique Louis 2013-10-07 06:15:49 UTC
This this an XWT issue.
Comment 3 Lluis Sanchez 2013-10-07 09:02:39 UTC
Fixed in master long time ago.
Comment 4 Akhilesh kumar 2013-10-31 14:07:56 UTC
We have checked this issue with the following builds:
Win 8 pro 
VS 2012/2013
MFA 4.10.01039
MTVS 1.8.233

Now activation dialog layout displayed properly even after setting larger display 

Screencast:http://www.screencast.com/t/XRfo21UsXpbg

Hence marking this issue as verified fixed.