Bug 13116 - Opening a Visual Studio project does not import components
Summary: Opening a Visual Studio project does not import components
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Component Store ()
Version: 4.0.9
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Matt Ward
URL:
Depends on:
Blocks:
 
Reported: 2013-07-09 07:01 UTC by Goncalo Oliveira
Modified: 2015-09-03 11:01 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Goncalo Oliveira 2013-07-09 07:01:58 UTC
Object

Visual Studio iOS project with two components referenced

. Google Maps
. SQLite.NET


Environment

Xamarin Studio 4.0.9 (build 12)


Description

When opening the project in XS (Mac), the project references aren't included. I always have to manually remove the references (from the references node) and download the component. Although the components folder is the same, it does not recognize the newly added components. Seems that the two machines have an independent repository reference and even though the files are there, the components aren't recognized. After downloading, I can finally add the components to the project again.
Comment 1 Goncalo Oliveira 2013-07-09 08:31:14 UTC
When doing the reverse, the same happens. Components are unreferenced even though the dll references stick.
Comment 2 Matt Ward 2015-09-03 11:01:38 UTC
Unable to reproduce this with Xamarin Studio 5.9. Please re-open if you can reproduce the bug.

With the Mac's Component cache cleared, I created a new iOS project in Visual Studio and added Google Maps and SQLite.NET components to it. Then pushed the solution to GitHub.

Checking out the project on the Mac with the Components directory already there containing the component assemblies worked OK. Also if the Components directory is not stored in GitHub when the solution is opened in Xamarin Studio the components will be downloaded again and restored.