Bug 13098 - [CorDebugger] Class could not be loaded: Exeption from HRESULT:0x80131303
Summary: [CorDebugger] Class could not be loaded: Exeption from HRESULT:0x80131303
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.0.9
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-07-08 11:40 UTC by Frederik
Modified: 2013-09-08 07:46 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
simple code from array (83.22 KB, application/pdf)
2013-07-08 11:40 UTC, Frederik
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Frederik 2013-07-08 11:40:50 UTC
Created attachment 4285 [details]
simple code from array

Description of Problem:
I did try to make a simple example from an array..The programme works perfect, but when you step into the code (in Debug or Release mode) I get in the window Watch an error when I try to see what it stores everytime into mine array.
The error is: Class could not be loaded: Exeption from HRESULT:0x80131303
I don't know if it is a problem from xamarin or .Net framework, because I did try the same example on mine Debian computer and there it is perfect!

Steps to reproduce the problem:
1. Mine code (simple console project C#)
code is attached in pdf document!

2. Run the code and put breakpoint at place where bytenummers go into the array
   In the window "WATCH" add the array with name dbArray!

Actual Results:
Class could not be loaded: Exeption from HRESULT:0x80131303

Expected Results:
See how the stored values get into the array

How often does this happen? 
Everytime

Additional Information:
I only have it with an Array, all the other declared bytes or integer values he does give correct!
Computer = Windows 7, all Net.frameworks are latest version + Xamarin version = 4.0.9 build 12!

I don't know if it is a bug into Xamarin, because it works perfect in Linux Debian???

Thanx & best regards,
Frederik
Comment 1 Jeffrey Stedfast 2013-07-09 09:49:05 UTC
Xamarin Studio on Mac and Linux use the Mono Soft Debugger backend, but on Windows, it uses the Windows CorDebugger backend when using the .NET runtime. If you install Mono and target the Mono runtime, then it will use the Soft Debugger backend and will work.

There are many bugs in the CorDebugger backend right now.
Comment 2 Marius Ungureanu 2013-09-08 07:46:23 UTC
This is fixed and will be included in future releases.