Bug 13091 - Getting build error for Android applications
Summary: Getting build error for Android applications
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: packaging ()
Version: unspecified
Hardware: PC Mac OS
: Highest blocker
Target Milestone: ---
Assignee: Duncan Mak
URL:
: 13093 ()
Depends on:
Blocks:
 
Reported: 2013-07-08 05:29 UTC by narayanp
Modified: 2013-08-01 10:44 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description narayanp 2013-07-08 05:29:36 UTC
Steps to reproduce this issue:
1. Open or create any android application.
2. Build the application.

Actual Result: Application giving build error "Compiler crashed with code: 127".

Expected Result: Application should build and deploy successfully.

Supplement info:
https://gist.github.com/atin360/aaf47f73df47ac661de6

Environment details:
X.S 4.0.9(build 15)
Mono 3.1.0
Xamarin.Android 4.7.11-34

Regresion Status: 
REGRESSION: This is working fine with MonoFramework 3.0.12
Comment 1 Zoltan Varga 2013-07-08 11:39:56 UTC
Do you have a /usr/bin/mcs symlink ? What does it point to ? Does the file it points to exists ?
Comment 2 PJ 2013-07-08 11:49:33 UTC
I don't see the symlink here, I've got:

Mono 3.1.0 1c4db5e
Android 4.7.11-34

> dynamic-069:bin pjbeaman$ file /usr/bin/mcs
> /usr/bin/mcs: cannot open `/usr/bin/mcs' (No such file or directory)
Comment 3 Zoltan Varga 2013-07-08 11:53:00 UTC
It looks like the 3.1.0 package is broken.
Comment 4 PJ 2013-07-08 17:20:02 UTC
*** Bug 13093 has been marked as a duplicate of this bug. ***
Comment 5 PJ 2013-07-12 21:17:26 UTC
The packaging issues were fixed, and new 3.1.1 builds have been dispersed to testers.
Comment 6 Mohit Kheterpal 2013-08-01 10:44:07 UTC
Today we have checked this issue on following builds :

X.S 4.0.11(build 6)
Mono 3.2.1 ((no/f3f789e)
Xamarin.Android 4.8.01010

Now we are able to build and deploy application on device and emulator successfully.

Hence closing this issue.