Bug 13076 - Syntax highlighting broken for F# syntax mode
Summary: Syntax highlighting broken for F# syntax mode
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-07-05 17:28 UTC by Dave Thomas
Modified: 2014-03-28 07:29 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot show 'let' highlighted incorrectly inside a property (62.20 KB, image/png)
2013-07-05 17:29 UTC, Dave Thomas
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Dave Thomas 2013-07-05 17:28:02 UTC
The F# syntax mode is maintained in MonoDevelop here:  https://github.com/mono/monodevelop/blob/master/main/src/core/Mono.Texteditor/SyntaxModes/FSharpSyntaxMode.xml

I have attached a screenshot showing an 'let' that is incorrectly highlighted in the middle of a property name.
Comment 1 Dave Thomas 2013-07-05 17:29:16 UTC
Created attachment 4279 [details]
screenshot show 'let' highlighted incorrectly inside a property
Comment 2 Mike Krüger 2013-07-11 04:57:43 UTC
fixed
Comment 3 Shruti 2014-03-28 07:29:12 UTC
I have verified this fix by copying the similar syntax mentioned in Description section. Please visit following screencast for same :
http://screencast.com/t/6Zbsb9Edfcq3

Environment Info:
=== Xamarin Studio ===

Version 4.2.4 (build 266)
Installation UUID: ce3f5199-e126-42fd-bc8a-6a96370af9ab
Runtime:
 Mono 3.2.6 ((no/9b58377)
 GTK+ 2.24.23 (Raleigh theme)

 Package version: 302060000

=== Xamarin.Android ===

Version: 4.13.0 (Trial Edition)
Android SDK: /Users/mac109/Desktop/android-sdk-macosx
 Supported Android versions:
  2.2   (API level 8)
  2.3   (API level 10)
  3.1   (API level 12)
  4.0   (API level 14)
  4.0.3 (API level 15)
  4.1   (API level 16)
  4.2   (API level 17)
  4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 5.0 (3332.22)
Build 5A1412

=== Xamarin.iOS ===

Version: 7.2.0.2 (Trial Edition)
Hash: 58c3efa
Branch: 
Build date: 2014-10-03 18:02:26-0400

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 402040266
Git revision: 57fa6b7639703775ae1d5c46536e42ab424cb177
Build date: 2014-03-20 12:34:27-04
Xamarin addins: eee141c29724a19529e77b8e743086d95b29f5ba

=== Operating System ===

Mac OS X 10.9.2
Darwin mac109s-Mac-mini.local 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64

Hence, marking as verified this issue.