Bug 13060 - Selected configuration changes when plugging in device.
Summary: Selected configuration changes when plugging in device.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: Trunk
Hardware: PC Mac OS
: Low minor
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
: 13555 ()
Depends on:
Blocks:
 
Reported: 2013-07-04 18:14 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2013-07-29 13:04 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2013-07-04 18:14:04 UTC
Repro:
* Disconnect device.
* Open iOS project.
* Select iOS Device configuration.
* Connect device.

Result: the configuration has switched to a simulator configuration.
Expected: the configuration should stay as a device configuration.
Comment 1 Jeffrey Stedfast 2013-07-09 16:00:40 UTC
it's because the generic iOS Device dummy target is no longer available so cannot be matched against by ID, so it chooses the first option in the list.
Comment 2 Jeffrey Stedfast 2013-07-29 11:01:59 UTC
*** Bug 13555 has been marked as a duplicate of this bug. ***
Comment 3 Jeffrey Stedfast 2013-07-29 13:04:00 UTC
fixed in git master